2017-02-23 48 views
0

Я относительно новый для углового 2. Я хочу использовать каталог угловых2-сетки. То, что я сделал, это создать папку для моего приложения со всем необходимым исходным файлом, а затем запустить npm-install. Установка завершена, и демо-приложение работает после того, как я набрал npm start. Затем я хочу настроить угловую2-сетку, а в official website говорит, что ей нужно ее использовать, вам просто нужно запустить npm install angular2-grid. Я попробовал это, но я получил некоторые предупреждения, как:angular2-grid каталог не застрахован

НПМ WARN [email protected] требует пэр @ угловой/ядро ​​@^2.4.4 но ни был установлен. npm WARN [email protected] требует равный из [email protected]^5.0.1, но ни один из них не был установлен. npm WARN [email protected] требует однорангового узла [email protected]^0.7.2, но ни один из них не был установлен.

Мне нужна помощь, как преодолеть эту проблему. Любое предложение приветствуется.

Мои package.json ниже:

{ 
"name": "product-management", 
"version": "1.0.0", 
"author": "Deborah Kurata", 
"description": "Package for the Acme Product Management sample application", 
"scripts": { 
    "start": "tsc && concurrently \"tsc -w\" \"lite-server\" ", 
    "tsc": "tsc", 
    "tsc:w": "tsc -w", 
    "lint": "tslint ./app/**/*.ts -t verbose", 
    "lite": "lite-server", 
    "typings": "typings", 
    "postinstall": "typings install" 
}, 
"license": "ISC", 
    "dependencies": { 
    "@angular/common": "2.0.0", 
    "@angular/compiler": "2.0.0", 
    "@angular/core": "2.0.0", 
    "@angular/forms": "2.0.0", 
    "@angular/http": "2.0.0", 
    "@angular/platform-browser": "2.0.0", 
    "@angular/platform-browser-dynamic": "2.0.0", 
    "@angular/router": "3.0.0", 

    "core-js": "^2.4.1", 
    "reflect-metadata": "^0.1.3", 
    "rxjs": "5.0.0-beta.12", 
    "systemjs": "0.19.27", 
    "zone.js": "^0.6.23", 

    "bootstrap": "^3.3.6" 
}, 
"devDependencies": { 
    "concurrently": "^2.2.0", 
    "lite-server": "^2.2.0", 
    "tslint": "^3.7.4", 
    "typescript": "^2.0.2", 
    "typings": "^1.0.4" 
}, 
"repository": {} 
} 

Благодаря

+0

вы можете поделиться пакетом .json? –

+0

@suraj Я разместил его ниже – Dea

+0

. Ваша существующая угловая версия и версия rxjs ниже, чем требуется «угловой сетке». Или пойдите для более старой версии 'angular-grid' или, если возможно, обновите свой проект –

ответ

0

существующую Angular version и RXJS version ниже, чем требует угловой сетки. Либо идти на старую версию угловой сетки или обновить ваш проект, если это возможно

Для вашего angular2-сетки, которые будут добавлен как зависимость в package.json вам нужно сделать

npm install angular2-grid --save 
0
{ 
"name": "product-management", 
"version": "1.0.0", 
"author": "Deborah Kurata", 
"description": "Package for the Acme Product Management sample application", 
"scripts": { 
    "start": "tsc && concurrently \"tsc -w\" \"lite-server\" ", 
    "tsc": "tsc", 
    "tsc:w": "tsc -w", 
    "lint": "tslint ./app/**/*.ts -t verbose", 
    "lite": "lite-server", 
    "typings": "typings", 
    "postinstall": "typings install" 
}, 
"license": "ISC", 
    "dependencies": { 
    "@angular/common": "2.0.0", 
    "@angular/compiler": "2.0.0", 
    "@angular/core": "2.0.0", 
    "@angular/forms": "2.0.0", 
    "@angular/http": "2.0.0", 
    "@angular/platform-browser": "2.0.0", 
    "@angular/platform-browser-dynamic": "2.0.0", 
    "@angular/router": "3.0.0", 

    "core-js": "^2.4.1", 
    "reflect-metadata": "^0.1.3", 
    "rxjs": "5.0.0-beta.12", 
    "systemjs": "0.19.27", 
    "zone.js": "^0.6.23", 

    "bootstrap": "^3.3.6" 
}, 
"devDependencies": { 
    "concurrently": "^2.2.0", 
    "lite-server": "^2.2.0", 
    "tslint": "^3.7.4", 
    "typescript": "^2.0.2", 
    "typings": "^1.0.4" 
}, 
"repository": {} 
} 
+0

отредактируйте вопрос. –

+0

@suraj Что-то, что кажется мне странным, это то, что угловая2-сетка существует как библиотека в каталоге ** node_modules **. Это человек, которого я уже установил? – Dea

+0

да .. для его добавления в качестве зависимости в package.json вам нужно сделать npm install angular2-grid --save' –